Back to overview
:|

Partial Proton Tunnel Outage

May 31 at 02:59am EDT
Affected services
Tunnel Japan #138
Tunnel Netherlands #89
Tunnel United States #37

Resolved
May 31 at 02:59am EDT

Continue to monitor status updates @ https://status.proton.me/incidents/w8d2d7lmbz32 for further info

Created
May 31 at 02:59am EDT

Partial Proton Tunnel Outage. We have not noticed any degradation to our services however.
Updates @ https://status.proton.me/incidents/w8d2d7lmbz32